
Dear customer 
 
LAPIS Semiconductor Co., Ltd. ("LAPIS Semiconductor"), on the 1st day of October, 
2020, implemented the incorporation-type company split (shinsetsu-bunkatsu) in which 
LAPIS established a new company, LAPIS Technology Co., Ltd. (“LAPIS 
Technology”) and LAPIS Technology succeeded LAPIS Semiconductor’s LSI business. 
 
Therefore, all references to "LAPIS Semiconductor Co., Ltd.", "LAPIS Semiconductor" 
and/or "LAPIS" in this document shall be replaced with "LAPIS Technology Co., Ltd." 
 
Furthermore, there are no changes to the documents relating to our products other than 
the company name, the company trademark, logo, etc.  
 
Thank you for your understanding. 
 

LAPIS Technology Co., Ltd. 
October 1, 2020 
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Figure 1  ML62Q1000 MCU Starter Kit hardware configuration 
 
 
 
 
■ Use with the U8/U16 Development Tools 

This section will take you through the process of building the ML62Q1000 Blink LED Sample, loading to the ML62Q1577 and 
running. 

 

 
 
 
 
 
 
 

Figure 2  Use with the U8/U16 Development Tools configuration 

 
 
1. Copy of ML62Q1000 MCU Starter Kit Software Package to your PC 
1-1. Connect the “ML62Q1000 MCU Starter Kit Software Package” USB memory to your PC. 
1-2. Copy the “ML62Q1000_MCU_ StarterKit” folder in the USB memory to the C drive’s root folder (C:\) of your PC. 

• Please copy the “ML62Q1000_MCU_StarterKit” folder to the folder the name of which is using half-width characters 

except space if you do not copy it to the C drive’s root folder (C:\) of your PC. 
 
1-3. Disconnect the USB memory from your PC. 

 
 
2. Installation of U8/U16 Development Tools 

This section will take you through the process of installing the U8/U16 Development Tools software, the Multiple Flash Writer, the 
Device Information Files and the EASE1000 V2 USB drivers. 
 

• Operating environment：Windows 7*, Windows 8.1*, Windows 10*   * 32-bit (x86) and 64-bit (x64) version. 

• Please log on as an administrator account. 

• When U8/U16 Development Tools existing in your PC, uninstall these programs at the beginning.  

For uninstallation, refer to Step #9. 

 
2-1. Extract the archives of the U8DevTool_Rx_xx_x.zip in the “ML62Q1000_MCU_StarterKit” folder that you copied in Step #1. 

*” Rx_xx_x” depends on the release version of the U8/U16 Development Tools. 
 

2-2. Double-click the U8DevInstaller.exe file in the “Setup” folder into which you extracted the U8DevTool_Rx_xx_x.zip. 
When this file is executed, the InstallShield Wizard will install the U8/U16 Development Tools software, the Multiple Flash Writer, 
the Device Information File and the EASE1000 V2 USB driver. 

 

• Follow the instructions of the InstallShield wizard to install.  

• Agree to “SOFTWARE LICENSE AGREEMENT for SOFTWARE DEVELOPMENT TOOLS”. 

• Do not change option settings. 

• Select “Complete” in the Setup Type selection part. 
 

When the InstallShield Wizard displays the “InstallShield Wizard Completed” message box finally, close it. 
After that, installation has finished. 

 
3. Connection 
3-1. As shown in figure 1 and figure 2, connect the ML62Q1577 Reference Board to the EASE1000 V2 On-Chip Emulator (hereinafter 

“EASE1000”). 
3-2. Connect the EASE1000 to PC using the USB cable. 

In case of Windows7, if you first connect EASE1000 to PC, the messages as the following Figure 3 and Figure 4 are displayed in 
sequence. 

 
 
 
 

Figure 3  The USB driver installation message 1              Figure 4  The USB driver installation message 2 

 
 

4. Installing the ML62Q1000 Blink LED Sample Program 
4-1. Extract the archives of the MCU_SampleProgram_vXXX.zip in the “ML62Q1000_MCU_ StarterKit” folder that you copied in Step 

#1. 
The ML62Q1000 Blink LED Sample Program (hereinafter “Blink LED Sample Program”) will be extracted into the 
“ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software” folder. 
 

                           *”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
 
 

5. Build of the Blink LED Sample Program and Launch of the DTU8 debugger 
This section will take you through the process of building the Blink LED Sample Program and launching the DTU8 debugger. 
 
You can select 2 methods to build the Blink LED Sample Program. 

• Using the Integrated Development Environment “IDEU8” (hereinafter “IDEU8”) 
You build the Blink LED Sample Program by using the IDEU8. 
Continue to Step “5a: In case of the IDEU8”. 

• Using the Eclipse-based LEXIDE-U16 Integrated Development Environment (hereinafter “LEXIDE-U16”) 
You build the Blink LED Sample Program by using the LEXIDE-U16 after you import the IDEU8 project file. 
Continue to Step “5b:  In case of the Eclipse-based LEXIDE-U16”. (the next page) 

 
< 5a:  In case of the IDEU8 > 

This section will take you through the process of building the Blink LED Sample Program by using the IDEU8, launching the 
DTU8 debugger from the IDEU8 and loading the Blink LED Sample Program to the ML62Q1577. 
 

• For details regarding the IDEU8, refer to the “IDEU8 User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > IDEU8 User’s Manual 
On the Window10: Start Menu > U8 Tools > IDEU8 User’s Manual 
 

5-1. Launch the IDEU8 from the Start Menu. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 > IDEU8 GUI Environment 
On the Window10: Start Menu > U8 Tools > IDEU8 GUI Environment 

5-2. Select the [File] menu > [Open... menu] command of the IDEU8. 
5-3. In the [Open File] dialog box, select the 0001_BlinkLED.PID which was extracted into the 

“ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software\0001_BlinkLED” folder in Step #4-1. 
                          *”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 
The project file of the Blink LED Sample Program will be opened. 
 

5-4. Click the [Build] button to compile, assemble and link the Blink LED Sample Program. 
  

 
You will be able to see the message “Finished building.” 

 
 

5-5. Click the [Debug] button to launch the DTU8 debugger 
 
 
 

5-6. In the “Target Settings” dialog box, select “ML621577” from LSI list of the “ML62Q1000” Category / ”ML62Q1500” Group of 
“Target chip”, and select ”On Chip Emulator” from the “Target ICE” list. And Click the [OK] button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5  Select the target chip and the target ICE 

 

5-7. Click the [OK] button when a confirmation dialog box will be displayed that asks the user whether to start debugging. 
The DTU8 debugger will load the Blink LED Sample Program. 
After finishing loading, the DTU8 debugger will display a source window as the following Figure 6. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 6  The DTU8 debugger 
 
Continue to Step #6 “Run of the Blink LED Sample Program by the DTU8 debugger” 
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< 5b:  In case of the Eclipse-based LEXIDE-U16 > 
This section will take you through the process of importing the IDEU8 project file of the Blink LED Sample Program by using the 
LEXIDE-U16, building the Blink LED Sample Program, launching the DTU8 debugger and loading the Blink LED Sample 
Program to the ML62Q1577. 
 

• For details regarding the LEXIDE-U16, refer to the “LEXIDE-U16 User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > LEXIDE-U16 User’s Manual 
On the Window10: Start Menu > U8 Tools > LEXIDE-U16 User’s Manual 

 
5-8. Launch the LEXIDE-U16 from the Start Menu. 

On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 > LEXIDE-U16 
On the Window10: Start Menu > U8 Tools > LEXIDE-U16 

The LEXIDE-U16 will display [Select a directory as workspace] dialog box after displaying a Splash Screen. 
5-9. In the [Workspace] field of the [Select a directory as workspace] dialog box, select the 

“ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software” folder which was extracted the 
MCU_SampleProgram_vXXX.zip in Step #4-1. And click the [Launch]. 

*”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
 
 
 
 

Figure 7  Select a “Workspace” folder in the [Workspace] field  
       of the [Select a directory as workspace] dialog box. 

 
A little while, the LEXIDE-U16 will launch. 

 
5-10. Select the [File] menu > [ Import…] menu command of the LEXIDE-U16. 

The [Import] dialog box will be opened. 
5-11. Select [LAPIS] > [IDEU8 project file(*.PID)] in the [Import] dialog box and click [Next] 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8  Select [LAPIS] > [IDEU8 project file(*.PID)] in the [Import] dialog box 
 

The [Import PID file] dialog box will be opened. 
 

5-12. Select “ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software\0001_BlinkLED” folder in the [Project path] field 
of the [Import PID file] dialog box. 
The selected folder contains the Blink LED Sample Program project file of the IDEU8. 

                          *”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9  Select “Project path” in the [Project path] of the [Import PID file] dialog box 
 

The Blink LED Sample Program project file of the IDEU8 will be displayed in the [Import PID file] dialog box. 
 

5-13. Select the [0001_BlinkLED.PID] which is displayed in the [Project list] field of the [Import PID file] dialog box. And click the 
[Finish] button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 10  Select the Blink LED Sample Program project file of the IDEU8  
in the [Import PID file] dialog box 

 
The Blink LED Sample Program project file of the IDEU8 will be imported to the LEXIDE-U16. 

 

 
 
 
 
 

5-14. Click the [Open Perspective] button in the top right of the LEXIDE-U16. 
 
 

 
The [Open Perspective] dialog box will be displayed. 
 

5-15. Select the [C/C++] in the [Open Perspective] dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11  Select the [C/C++] in the [Open Perspective] dialog box. 
 
The toolbar will be changed for the [C/C++ Perspective] as the following Figure12. 

 
 
 

Figure 12  The [C/C++ Perspective] toolbar 
 

5-16. Select the [0001_BlinkLED] of the [Project Explorer]. 
 
 
 
 
 
 
 
 
 

Figure 13  Select the [0001_BlinkLED] of the LEXIDE-U16’s [Project Explorer] 
 

5-17. Click the [Build] button to compile, assemble and link the Blink LED Sample Program. 
 
 
 

 
You will be able to see the message “Build Finished.” 
 

5-18. Click the [LAPIS] menu > [Debug(DTU8)] menu comamd to launch the DTU8 debugger and load the Blink LED Sample 
Program. 

 
 
 
 
 
 
 
 
 

Figure 14  Select the [LAPIS] menu > [Debug(DTU8)] 
 

• You cannot use [RUN] menu command to launch the DTU8 debugger. 
 
The DTU8 debugger will launch and load the Blink LED Sample Program. 
After finishing loading, the DTU8 debugger will display a source window as the following Figure 15. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 15  The DTU8 debugger 



 
 
 
 
 

6. Run of the Blink LED Sample Program by the DTU8 debugger 
6-1. Click the [Reset and Restart] button of the DTU8 debugger 

 
 
 
 
 

The Blink LED Sample Program run, and 3 LEDs on the ML62Q1577 Reference Board will blink. 
 

• For details regarding the DTU8 debugger, refer to the “DTU8 debugger User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > DTU8 User’s Manual 
On the Window10: Start Menu > U8 Tools > DTU8User’s Manual 

 
7. Stop of the Blink LED Sample Program 
7-1. Click the [Stop] button of the DTU8 debugger. 

The Blink LED Sample Program will stop. 
 

8. Shut down 
< DTU8 Debugger> 

8-1. Select the [File] menu > [Exit] menu command of the DTU8 debugger. 
8-2. Click the [OK] button when a confirmation dialog box will be displayed that asks the user whether to terminate DTU8 debugger.  
8-3. Click the [No] button when a confirmation dialog box will be displayed that asks the user whether to save current settings to project 

file.  
The DTU8 debugger will shut down. 

 
<In using IDEU8 case > 

8-4. Select the [File] menu > [Exit] menu command of the IDEU8 
8-5. Click the [Yes] button when a confirmation dialog box will be displayed that asks the user whether to stop IDEU8. 
8-6. Click the [Yes] button when a confirmation dialog box will be displayed that asks the user whether to save current settings to project 

file. 
The IDEU8 will shut down. 
Continue to Step #8-8 

 
<In using LEXIDE-U16 case > 

8-7. Select the [File] menu > [Exit] menu command of the LEXIDE-U16 
The LEXIDE-U16will shut down. 

 
<Hardware > 

8-8. Disconnect the USB cable which is connected to the EASE1000 from your PC. 
 

9. Uninstallation 

• Uninstalling U8/U16 Development Tools Release 2.00.0 or later 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Environment Setup : LAPIS Semiconductor U8/U16 Development Environment Setup 

 

You will be able to uninstall all of the bellow U8/U16 Development Tools. 

- U8/U16 Development Tools software (build tools) : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Development Tools software (GUI tools) : LAPIS Semiconductor U8/U16 Development Tools 

- Multiple Flash Writer   : LAPIS Semiconductor MWU16 Multiple Flash Writer 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver 
 

• Uninstalling U8/U16 Development Tools Release 1.xx.x or earlier. 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Tools software  : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver*1 

*1: There is not USB driver in the U8/U16 Development Tools Release 1.15.4 than earlier. 
 

10. The Software Development Support System 
When you need the latest version of the U8/U16 Development Tools software and the ML62Q1000 Series Reference Software, you 
can download the latest version from “LAPIS Semiconductor support site” (hereinafter “Support Site”) is a special website that 
gives registered users. 
Registration is required to access the site using an ID and Password. 
Navigate to the support page by clicking on a link on LAPIS Semiconductor's home page or by entering the URL in the browser's 
address bar. Then click on the 'Register' link. 

LAPIS Semiconductor support site URL 
https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi 

 
* In order to download the software such as the software development support system, you need to register the 

serial number of the EASE1000 V2 at the time of registration.  
At the time of registration, select “Microcontroller / speech Synthesis LSI”, "EASE1000 V2 " and type "The 
serial number of EASE1000 V2" as follows. 
 

Category: Microcontroller / speech Synthesis LSI 
Development/evaluation tool name: EASE1000 V2 
The serial number of development tool: The serial number of EASE1000 V2 
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