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Welcome to the SparkFun Inventor’s Guide

The SparkFun Inventor's Guide is your map for navigating the
waters of beginning embedded electronics. This booklet contains
all the information you will need to explore the 16 circuits of the
SparkFun Inventor's Kit for SparkFun RedBoard. At the center of
this manual is one core philosophy - that anyone can (and

should) play around with electronics. When you're done with this
guide, you'll have the know-how to start creating your own
projects and experiments. Now enough talking - let's get
inventing!

www.sparkfun.com/SIK
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is the RedBoard platform?

The DIY Revolution

We live in a unique time where we have access to resources
that allow us to create our own solutions and inventions. The
DIY revolution is composed of hobbyists, tinkerers and
inventors who would rather craft their own projects than let
someone do it for them.

www.sparkfun.com

A Computer for the Physical World

The RedBoard in your hand (or on your desk) is your
development platform. At its roots, the RedBoard is
essentially a small portable computer. It is capable of
taking inputs (such as the push of a button or a reading
from a light sensor) and interpreting that information to
control various outputs (like a blinking LED light or an
electric motor).

That's where the term "physical computing” is born -
this board is capable of taking the world of electronics
and relating it to the physical world in a real and tangjble
way. Trust us - this will all make more sense soon.

RedBoard

// SparkFun RedBoard

The SparkFun RedBoard is one of a multitude of
development boards based on the ATmega328. It has 14
digital input/output pins (6 of which can be PWM E

. . = scLe=
outputs), 6 analog inputs, a 16 MHz crystal oscillator, a i L = spa=
USB connection, a power jack, an ISP header, and a reset . AREF @
button. Don’t worry, you’ll learn about all these later.

B 10REF
B RESET
B33V
B5V
BEND 3
BEND=
m
BVIN T

B A0

= A1

= A2
= A3
=3
® Ad
B A5
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Download the Arduino IDE (integrated Development Environment)

Access the Internet

In order to get your RedBoard up and running, you'll need to
download the newest version of the Arduino software first from
www.arduino.cc (it's free!). This software, known as the Arduino
IDE, will allow you to program the board to do exactly what you
want. It’s like a word processor for writing programs. With an
internet-capable computer, open up your favorite browser and

type in the following URL into the address bar:

w arduino.cc/en/main/software | - case sensitive >

( N
Select the installer option appropriate

Download . :
for the operating system you are using.

+ Windows
+ MacOS X
4+ Linux: 32 bit, 64 bit

+ source

ARDUINO

Download the Arduino Software

' ARDUINO 1.6.13

0 Choose the appropriate Operating System installation package for your computer.
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// Connect your RedBoard to your Computer

Use the USB cable provided in the SIK kit to connect the RedBoard to
one of your computer’s USB inputs.

// Install Arduino Drivers

Depending on your computer’s operating system, you will need to follow specific
instructions. Please go to www.sparkfun.com/FTDI for specific instructions on how to
install the FTDI drivers onto your RedBoard.
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// Open the Arduino IDE:

Open the Arduino IDE software on your computer. Poke around and get to know
the interface. We aren’t going to code right away, this is just an introduction. This
step is to set your IDE to identify your RedBoard.




GU' (Graphical User Interface)

1  Verify: Compiles and approves your code. It will catch errors in syntax (like missing semi-colons or parenthesis). '~ See Diagram Below
Uploa Sends your code to the RedBoard. When you , you should see the lights on your boal

4 Ope This button will let you open up an existing sketch. See Diagram Below

5 ' Save: This saves the currently active sketch.

6 Serial Monitor: This will open a window that displays any serial information your RedBoard is transmitting. It is very useful for debugging.

7 = Sketch Name: This shows the name of the sketch you are currently working on.

8 Code Area: This is the area where you compose the code for your sketch.

9 Message Area: This is where the IDE tells you if there were any errors in your code.

10 Connection Area: This shows the board and serial port currently selected.

// The three most important commands for this guide are these:

Open Verify

Upload



ial Device

// Select your S
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// Select your board: Arduino/Genuino Uno

Arduino File Edit Sketch Help

Auto Format ®T
Archive Sketch

Fix Encoding & Reload

Serial Monitor T #EM
Serial Plotter 3L
WiFi101 Firmware Updater

Board: "Arduino/Genuino Uno" »
Port: "/dev/cu.Bluetooth-Modem” >
Get Board Info

Programmer: "AVRISP mkll" >

Burn Bootloader

Note:
Your SparkFun RedBoard and the
Arduino/Genuino UNO are interchangeable
but you won't find the RedBoard listed in
the Arduino Software. Select “Arduino
UNO” instead.

Boards Manager...

Arduino Yun

Arduino/Genuino Uno h)
Arduino Duemilanove iecimila
Arduino Nano

Arduino/Genuino Mega or Mega 2560
Arduino Mega ADK

Arduino Leonardo
Arduino/Genuino Micro

Arduino Esplora

Arduino Mini

Arduino Ethernet

Arduino Fio

Arduino BT

LilyPad Arduine USB

LilyPad Arduino

Arduino Pro or Pro Mini

Arduino NG or older

Arduino Robot Control

Arduino Robot Motor

Arduino Gemma

Select the serial device of the Ardui
RedBoard from the Tools | Taoks| Help
Serial Port menu. This is likely Auto Format Crl+T
to be com3 or higher Auchive Sketch
FixEncoding & Reload
COM1 and COM2 are
( wially reserved for harduwar Serial Monitor Ctrl+Shift b
. usually reserved tor hardware Serial Plotter Ctrl+Shift L
serial ports). To find out, you can disconnect
your RedBoard and re-open the menu; the entry Bl Yl eamim We- "
that disappears should be the RedBoard. Fort Serial ports
Reconnect the board and select that serial port. (et oard Infe comt
oMz
Programmer: "AVRISP mkI"
COMS1 (Arduino/ Genuino Uno)
Burn Bootloader
Arduino  File Edit Sketch Help
Auto Format ®T
) Archive Sketch
Select the serial Fix Encoding & Reload
device of the Serial Monitor 0 %/M
RedBoard from Serial Plotter {3l
the Tools > WIFi101 Firmware Updater
Serial Port . .
Board: "Arduino/Genuino Uno" »

menu. On the

Port: "/dev/cu.Bluetocoth-Modem"”
Mac, this should be something Get Board Info
with /dev/tty.usbmodem or

L Programmer: "AVRISP mkll" >
/dev/tty.usbserial in it.

Burn Beotloader

/dev/cu/Bluetooth-Incoming-Port
k/dev/cu.usbserialDNm 8JWS

hetp://www.arduino.cc/playground/Learning/Linux



Download Arduino Code (For use with the circuits in this guide)

Type in the following URL to download the code:

sparkfun.com/sikcode

(5 start —» [ Programs —» [ arduino —3 [ examples

:

Unzip the file “SIK Guide Code”. It

should be located in your browser’s « . » . .
Copy the “SIK Guide Code” fold Ard
“Downloads” folder. Right click the S pide toce Toider fio frduino s

zipped folder and choose “unzip”.

folder named “examples”.

. @ Contents
e '
(38 Resources
Find “Arduino” in your applications *
folder. Right click(ctr] + click) on | Java
“Arduino”. Select “Show Package
Unzip the file “SIK Guide Code”. It Cramienis *
should be loacted in your browser’s i examples
“Downloads” folder. Right click the Arduino
zipped folder and choose “unzip”. Open

Copy the “SIK Guide Code” folder into
Arduino’s folder named “examples”.

Show Package Contents

Move to Trash

22

& http://www.arduino.cc/playground/Learning/Linux

WHAT’S NEXT? Read on to learn more about getting started with circuits. Then you can start on your first circuit on page 17!

// Copy “SIK Guide Gode” into “Examples” library in Arduino folder
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Getting Started with Circuits

What is an Electrical Circuit?

@ A circuit is basically an electrical loop with a starting point and an
ending point - with any number of components in between.
Circuits can include resistors, diodes, inductors, sensors of all sizes
$ and shapes, motors, and any other handful of hundreds of

thousands of components.

I I Circuits are usually divided into three categories - analog circuits,
digital circuits, or mixed-signal circuits. In this guide, you will
explore all three sets of circuits.

The World Runs on Circuits:

Everywhere you look, you'll find circuits. The cell )
phone in your pocket, the computer that controls

your car's emissions system, your video game I
console - all these things are chock full of circuits.

In this guide, you'll experiment with some simple

circuits and learn the gist of the world of embedded
electronics.

ODNNOEDEOEOE@IDOEDED

OOEE DEDNED DEOEE

- N + - abcde fghi;‘+ -

// Simple and Complex Circuits m= EEEe || pomne

mEEEE

. . . . . . 3

In this guide, you will be primarily exploring EE JHEEEE
simple circuits - but that doesn't mean you can't ELemst 5 ¢
do amazing things with simple tools! When you've ] & .
finished the SIK, your knowledge of circuits will g M E o
enable you to explore amazing projects and CEINE = %
unleash the power of your imagination. g b= "
= 15EH 15
= 8E ®
= vE 7
BE 8
»
E 20
21
E 2

=

=
by

OEODOR ODOOED ONEND SOORNE DOEODD

\l+
jag ===
DOOEE

or

+@@@@@ HEDEH DENEHED HEDEHE SDEEE

cOREIERET
o OHEDEDEDNDENEDED

+
1
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Inventory of Parts

Jumper Wire —— LED (5mm) (l—+

Various Colors (Light Emitting Diode)

330Q2 Resistor 10KQ Resistor

§ §
* ACTUAL SIZE * ACTUAL SIZE
Potentiometer Diode
M . (1N4148)
* ACTUAL SIZE
x1
Photo Resistor Piezo Buzzer
x1 ! I x1

Transistor
=R
BACK
X2

o&
OO !

Temp. Sensor
(TMP36)

DC Motor

—
oo
.I.
—

M
—
oo
.I.
—
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Flex Sensor

x1

Soft Potentiometer

x1

x1

SparkFun RedBoard

aaaaaa
NI 90TYNY

x1

Relay

Integrated Gircuit
(ic)

LCD

Breadboard

Standard Solderless (Color may vary)

+
1

OO DHEOED DOOOE HEEEE DEREEO
OO DEOOD HOHEHE HEEEE HEEEOE
3
=
=

+
1
[}
o
a
(-
o

1) 0 O 02 <) 0 O O O] ) O O
N I8N aERS

+
1

DHOENE DHEEHE DEOEE DEEEE EHEEER
o= s = = v f s f v = v s s = (= (= = f =

+ -

x1
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SparkFun RedBoard

Power In (Barrel Jack) - Can be used with either a 9V or 12V wall-wart or battery.

Power In (USB Port) - Provides power and communicates with your board when plugged into your computer via USB.

LED (RX: Receiving) - This shows when the FTDI chip is receiving data bits from the microcontroller. This happens when the microcontroller is
sending data bits back to the computer.

LED (TX: Transmitting) - This shows when the FTDI chip is transmitting data bits to the microcontroller. This happens when the
microcontroller is receiving this data from the computer.

LED (Pin 13: Troubleshooting) - This LED is incorporated into your sketch to show if your program is running properly.

Pins (ARef, Ground, Digital, Rx, Tx) - These various pins can be used for inputs, outputs, power, and ground.  See Diagram Below

LED (Indicates RedBoard is ON) - This is a simple power indicator LED.

Reset Button - This is a way to manually reset your RedBoard, which makes your code restart.

ICSP Pins (uploading Code without Bootioader) - This is for "In-Circuit Serial Programming,” used if you want to bypass the bootloader.
Pins (Analog In, Power In, Ground, Power Out, Reset) - These various pins can be used for inputs, outputs, power, and ground. ~ See Diagram

RFU - This pin is reserved for future use.

// Pins Diagram

S N

The header pins are one of the most important parts for putting our
0 example circuits together. Take a moment and locate the inp pi
ports of your RedBoard.
se. |
RFU SO
AREF ARef
GND Ground
@ rru o
[— 13 Digital
IOREF
12 Digital
Reset RESET o
~11 Digital
Power Out 3.3V
~10 Digital
Power Out 5v
~9 Digital
Ground GND o
o 8 Digital
Ground GND Q
s -
|) Powerin VIN 3 7 Digital
g -6 Digital
Analog Ao ° 3 -5 Digital
Analog Al - 4 Digital
> b -
Analog A2 § s -3 Digital
Analog A3 o E 2 Digital
Analog Ad ;. ™1 X - out
Analog \AS O O RX <0 RX-In |

o~ =PWM/Analog out compatible (i.e.~3)
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fFghij

This line divides the board in half, restricting electricity to one half or the other.
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Breadboard

1  Vertical Connection (+ Power and - Ground) - Power bus '~ See Diagram Below

2 Horizontal Connection (a-e & f-) ~ See Diagram Below)

+++++++
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CIRCUIT #1 - Your First Circuit

How It Works:

1 ASSEMBLE 2 WRITE 3 UPLOAD

+ Make sure the text on the RedBoard and
breadboard are facing up so you can read them.

+ Connect the USB cable.

+ Screw the RedBoard down and into place.

+ Peel sticker off back of
breadboard and stick into place.

Your RedBoard runs on 5V. This is the power that will be supplied from your computer via USB and
will be the driving force behind any components you use in your circuits. By plugging your RedBoard
into your computer, you are supplying it with just the right voltage it needs to thrive! 5V can’t hurt you,
so don’t be afraid to touch anything in your circuit. You can also power the RedBoard through the
barrel jack. The on-board voltage regulator can handle anything from 7 to 15VDC.
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RedBoard

LED
/ (Light-Emitting Diode)

A\N
I

§ Resistor (330 ohm)
(Orange-Orange-Brown)

_1 _ GND
= (Ground)

+ This is a schematic of your circuit.

Blinking an LED

LEDs (light-emitting diodes) are small, powerful lights
that are used in many different applications. To start off
the SIK, we will work on blinking an LED. That's right
- it's as simple as turning a light on and off. It might
not seem like much, but establishing this important
baseline will give you a solid foundation as we work
toward more complex experiments.

+ Each circuit begins with a brief description
of the what you are putting together and
the expected result.

will need to complete the circuit.

LED 330Q Wire
/ Resistor
x1 x1 x3< + This section lists the parts you

+ This is an illustration of how the
completed circuit should look. It is not
necessary to use the black holder for the
RedBoard and breadboard, but we
recommend it for the first time inventor!

+ Components like resistors need to have
their legs bent into 90° angles in order to
correctly fit the breadboard sockets. You
can also cut the legs shorter to make them
easier to work with on the breadboard.
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Open Up the Arduino IDE software on your computer. Coding in the Arduino
language will control your circuit. Open the code for Circuit 1 by accessing the “SIK
Guide Code” you downloaded and placed into your “Examples” folder earlier.

. [T Edit Sketch Tools  Help

New
Open...
Sketchbook >
1.Basics »
Close 2.Digital >
Save 3.Analog >
Save As... 4.Communication >
Upload 5.Control >
Upload Using Progammer 6.Sensors >
7.Displays >
Page Setup 8.Strings 4
Print ArduinolSP
Circuit #2
EEPROM Circuit #3
Ethernet Circuit #4
Firmata Circuit #5
Liquid Crystal Circuit #6
SD Circuit #7
Servo Circuit #8
SoftwareSerial Circuit #9
SPI Circuit #10
Stepper Circuit #11
Wire Circuit #12
Circuit #13
Circuit #14
Circuit #15
// Circuit #1

Circuit #1

Blink
Turns on an LED on for one second,
then off for one second, repeatedly.

This example code is in the public domain

void setup() {

initialize the digital pin as an output

Pin 13 has an LED connected on most Arduino boards:
pinMode(13, OUTPUT);

void loop() {
rite(13, HIGH); // set the LED on

delay(1000); wait for a second
d (13,LOW); // set the LED off
delay(1000); wait for a second

}
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N

This compiles your code. The IDE changes it from text into instructions the computer

can understand.

J Verify

This sends the instructions via the USB cable to the computer chip on the RedBoard. The

RedBoard will then begin running your code automatically.

Upload

>

t with correct code after verified and uploaded.

ul

// The result of a completed circ.

Page 23



+ This is where you will find the
Arduino code for each circuit.

\ u Open Arduino IDE // File > Examples > SIK Guide > Circuit # 1
Code to Note: + Remember to Verify and >o o

Upload your code.

+ Begin to understand how the
Arduino code works. See below.

Before you can use one of the RedBoard's pins, you need to tell the
pinMode(13, OUTPUT); RedBoard whether it is an INPUT or OUTPUT. We use a built-in
"function" called pinMode() to do this.

digitalWrite(13, HIGH); When you're using a pin as an OUTPUT, you can command it to be
’ ’ HIGH (output 5 volts), or LOW (output 0 volts).

What you Should see. + See if your circuit is complete

and working in this section.

You should see your LED blink on and off. If
itisn't, make sure you have assembled the

circuit correctly and verified and uploaded the
code to your board or see the troubleshooting
tips below.

+ Here you will find examples of the circuit
you just completed in the real world.

Many of the theories in these circuits are

used in things you use everyday!

+ This is a section dedicated to the most
common mistakes made while assembling
the circuit.

Troubleshooting: Real World Application:

LED Not Lighting Up? Almost all modern flat screen televisions and monitors
LEDs will only work in one direction. Tty taking it out, have LED indicator lights to show they are on or off.
turning it 180 degrees and reinserting it (no need to worry,
installing it backward does no permanent harm).

Program Not Uploading
"This happens sometimes, the most likely cause is a confused
serial port, you can change this in tools>serial port>

Still No Success?
A broken circuit is no fun, send us an e-mail and we will get

back to you as soon as we can: techsupport@sparkfun.com
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Potentiometer

PIN 13 |RedBoard

In this circuit you’ll work with a potentiometer.
A potentiometer is also known as a variable resistor.
LED When it’s connected with 5 volts across its two outer
\/ (Light-Emitting Diode) pins, the middle pin outputs a voltage between 0 and
5, depending on the position of the knob on the
potentiometer. A potentiometer is a perfect
PIN A demonstration of a variable voltage divider circuit.
RedBoard The voltage is divided proportionate to the resistance
Resistor (330 ohm) between the middle pin and the ground pin. In this
(Orange-Orange-Brown) A s .
circuit, you'll learn how to use a potentiometer to
control the brightness of an LED.

5 volt

AN

Potentiometer

MM

Potentiometer LED 330Q Wire

Resistor
x1
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Circuit 2: Potentiometer
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J ’ I Open Arduino IDE // File > Examples > SIK Guide > Circuit # 2

00

A “variable” is a stored value you've given a name to. You must introduce,
. r "declare” variables befor hem; here we're declarin riabl
int sensorValue; :> or "declare" variat esleoeniyoglllset em; here we e decla gava able
called sensorValue, of type "int" (integer). Don't forget that variable names

are case-sensitive!

We use the analogRead() function to read the value on an analog

sensorValue = analogRead(sensorPin); :> pin. analogRead() takes one parameter, the analog pin you want
to use ("sensorPin"), and returns a number ("sensorValue")
between 0 (0 volts) and 1023 (5 volts).

The Arduino is very very fast, capable of running thousands of lines of code
:> each second. To slow it down so that we can see what it's doing, we'll often

delay(sensorValue);
insert delays into the code. delay() counts in milliseconds; there are 1000 ms

in one second.

What you Should See:

You should see the LED blink faster
or slower in accordance with your
potentiometer. Ifit isn't working,
make sure you have assembled the
circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

Troubleshooting: Real World Application:

Sporadically Working Most traditional volume knobs employ a potentiometer.
This is most likely due to a slightly dodgy connection
with the potentiometer's pins. This can usually be
conquered by holding the potentiometer down.

Not Working

Make sure you haven’t accidentally connected the
wiper, the resistive element in the potentiometer, to
digital pin 0 rather than analog pin 0. (the row of pins
beneath the power pins).

LED Not Lighting Up?

LEDs will only work in one direction. Tty taking it out and
turning it 180 degrees (no need to worty, installing it
backward does no permanent harm).
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T RGB LED
RedBoard You know what’s even more fun than a blinking

LED? Changing colors with one LED. RGB, or
red-green-blue, LEDs have three different color-emit-
ting diodes that can be combined to create all sorts of
Resistors (330 ohm) colors. In this circuit, you'll learn how to use an RGB
(Orange-Orange-Brown) LED to create unique color combinations.
Depending on how bright each diode is, nearly any
color is possible!

B LED
(Light-Emitting Diode)

GND
— (Ground)

3 LED 330Q Wire
% Resistor
x1 x3 x6
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Circuit 3: RGB LED
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1 ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 3

00

A for() loop is used to step a number across a range, and repeatedly runs

for (x = 05 x <767; x++) :> code within the brackets {}. Here the variable "x" starts a 0, ends at 767,

it and increases by one each time ("x++").

if (x <= 255) "If / else" statements are used to make choices in your programs. The statement

i :> within the parenthesis () is evaluated; if it's true, the code within the first brackets {}
else will run. Ifit's not true, the code within the second brackets {} will run.

{

The RedBoard is very very fast, capable of running thousands of lines of
. code each second. To slow it down so that we can see what it's doing,
delay(sensorValue); . ) ) A
we'll often insert delays into the code. delay() counts in milliseconds;

there are 1000 ms in one second.

What you Should See:

You should see your LED turn on,

but this time in new, crazy colors! If it
isn't, make sure you have assembled
the circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color Many electronics such as

With the four pins of the LED so close together, it’s videogame consoles use RGB

sometimes easy to misplace one. Double check each LED:s to have the versatility

pin is where it should be. to show different colors in
the same area. Often times

Seeing Red the diffent colors represent

The red diode within the RGB LED may be a bit brighter different states of working

than the other two. To make your colors more balanced, condition.

use a higher Ohm resistor. Or adjust in code.

analogWrite(RED_PIN, redIntensity);

to

analogWrite(RED_PIN, redIntensity/3);
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CIRCUIT #4

RedBoard
N 4 4N 4Y LEDs
T 7T T 77 (Light-Emitting Diodes)
s s s Resistors (330 ohm)
s s 3 (Orange-Orange-Brown)
‘TL GND (Ground)
RedBoard
edBoar

LEDs
(Light-Emitting Diodes)

Resistors (330 ohm)
(Orange-Orange-Brown)

AW
WW-

AMA
WW-

AW
WW-

= GND (Ground)

LED 330Q Wire
/% Resistor
x8 x8 x10

Multiple LEDs

So you have gotten one LED to blink on and off —
fantastic! Now it's time to up the stakes a little bit — by
connecting EIGHT LEDS AT ONCE. We'll also give
our RedBoard a little test by creating various lighting
sequences. This circuit is a great setup to start practicing
writing your own programs and getting a feel for the
way RedBoard works.

Along with controlling the LEDs, you’ll learn about a
couple programming tricks that keep your code neat
and tidy:

for() loops - used when you want to run a piece of
code several times

arrays| ] - used to make managing variables easier by
grouping them together
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J ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 4

00

When you have to manage a lot of variables, an "array" is

int ledPins[] = {2,3,4,5,6,7,8,9}; :> a handy way to group them together. Here we're creating
an array of integers, called ledPins, with eight elements.

You refer to the elements in an array by their position.
The first element is at position 0, the second is at position

digitalWrite(ledPins[0], HIGH); :> ‘1, etc. Yo.u-refer to an el'emen[ L}slng l-edPu‘]s [x]" where x
is the position. Here we're making digital pin 2 HIGH,
since the array element at position 0 is "2".

Computers like to do the same things each time they run. But sometimes

. _ you want to do things randomly, such as simulating the roll of a dice. The

index = random(8); ’ o ’ .
random() function is a great way to do this.

See http://arduino.cc/en/reference/random for more information.

What you Should See:

"This is similar to circuit number one, but
instead of one LED, you should sece all the
LEDs blink. If they aren't, make sure you
have assembled the circuit correctly and
verified and uploaded the code to your board
or see the troubleshooting tips below.

Troubleshooting: Real World Application:

Some LEDs Fail to Light Scrolling marquee displays are generally used to spread
It is easy to insert an LED backwards. Check the LEDs short segments of important information. They are built
that aren't working and ensure they the right way out of many LEDs.

around.

Operating out of sequence
With eight wires it's easy to cross a couple. Double check
that the first LED is plugged into pin 2 and each pin ‘ [

there after.

Starting Afresh

Its easy to accidentally misplace a wire without noticing.
Pulling everything out and starting with a fresh slate is
often easier than trying to track down the problem.
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Push Buttons

5 volt

Up until now, we’ve focused solely on outputs. Now
we're going to go to the other end of spectrum and
play around with inputs. In this circuit, we’ll be
looking at one of the most common and simple
inputs — a push button. The way a push button works
with RedBoard is that when the button is pushed, the
voltage goes LOW. The RedBoard reads this and
reacts accordingly. In this circuit, you will also use a
pull-up resistor, which keeps the voltage HIGH when
you're not pressing the button.

Resistors (10K ohm)
(Brown-Black-Orange)

LED
(Light-Emitting Diode)

RedBoard

Buttons

Resistors (330 ohm)
(Orange-Orange-Brown)

il

= GND
(Ground)

Push Button LED 10KQ 330Q Wire

Resistor Resistor
x2 x1 x2 x1 x7
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Circuit 5: Push Buttons
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1 ’ I Open Arduino IDE // File > Examples > SIK Guide > Circuit # 5

00

The digital pins can be used as inputs as well as outputs.
pinMode(button2Pin, INPUT); :> Before you do either, you need to tell the RedBoard
which direction you're going.

To read a digital input, you use the digitalRead()
buttonlState = digitalRead (button1Pin); function. It will recurn HIGH if there's 5V present at the
pin, or LOW if there's OV present at the pin.

Because we've connected the button to GND, it will read LOW when
if (button1State == LOW) it's being pressed. Here we're using the "equivalence” operator ("==")
to see if the button is being pressed.

What You Should See:

You should see the LED turn on
if you press either button, and off
if you press both buttons. (See the
code to find out why!) If itisn't
working, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board or see the
troubleshooting tips below.

Troubleshooting:

Light Not Turning On The buttons we used here are similar to the buttons in
The pushbutton is square, and because of this it is easy most video game controllers.

to put it in the wrong way. Reinsert it turned 90 degrees

in the breadboard and see if it starts working.

Light Not Behaving as Expected with Button Push
Double check that your resistors are inserted properly in
the breadboard. If your button is left floating (not
pulled HIGH to 5V), you may see some erratic
behavior of the LEDs.
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CIRCUIT #6

Photo Resistor

5 volt So you've already played with a potentiometer, which
varies resistance based on the twisting of a knob. In
this circuit, you’ll be using a photo resistor, which

Photocell changes resistance based on how much light the

(Light Sensitive Resistor) sensor receives. Since the RedBoard can’t directly
interpret resistance (rather, it reads voltage), we use a

voltage divider to use our photo resistor. This voltage
divider will output a high voltage when it is getting a

Resistor (10K ohm) lot of light and a low voltage when it is not.
(Brown-Black-Orange)

LED
(Light-Emitting Diode)

RedBoard

Resistor (330 ohm)
(Orange-Orange-Brown)

= GND
(Ground)
Photo Resistor LED 330Q Wire 10KQ
§§ Resistor Resistor
x1 x1 x1 x6 x1

3
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Circuit 6 : Photo Resistor
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1 ’ I Open Arduino IDE // File > Examples > SIK Guide > Circuit # 6

lightLevel = map(lightLevel, 0, 1023, 0, 255); |:>
Parameters
map(value, fromLow, fromHigh, toLow, toHigh)

value: the number to map

fromLow: the lower bound of the value's current range
fromHigh: the upper bound of the value's current range
toLow: the lower bound of the value's target range
toHigh: the upper bound of the value's target range

lightLevel = constrain(lightLevel, 0, 255);

Parameters

=

constrain(x, a, b)

x: the number to constrain, all data types
a: the lower end of the range, all data types
b: the upper end of the range, all data types

What You Should See:

You should see the LED grow brighter
or dimmer in accordance with how
much light your photoresistor is
reading. If it isn't working, make sure
you have assembled the circuit
correctly and verified and uploaded
the code to your board or see the
troubleshooting tips below.

Troubleshooting:

LED Remains Dark

Tis is a mistake we continue to make time and time
again, if only they could make an LED that worked
both ways. Pull it out and rotate it 180 degrees.

It Isn't Responding to Changes in Light

Given that the spacing of the wires on the photo-resistor
is not standard, it is easy to misplace it. Double check it’s
in the right place.

Still Not Quite Working

You may be in a room which is either too bright or dark.
Try turning the lights on or off to see if this helps. Or if
you have a flashlight near by give that a try.
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When we read an analog signal using analogRead(), it will be
a number from 0 to 1023. But when we want to drive a
PWM pin using analogWrite(), it wants a number from 0 to
255. We can "squeeze" the larger range into the smaller range
using the map() function.

See http://arduino.cc/en/reference/map for more info.

Because map() could still return numbers outside the "to"
range, we'll also use a function called constrain() that will
"clip" numbers into a range. If the number is outside the
range, it will make it the largest or smallest number. If it is

within the range, it will stay the same.

See http://arduino.cc/en/reference/constrain for more info.

Real World Application:

A street lamp uses a light sensor to detect when to turn

the lights on at night.

I



PIN AO
RedBoard

Temperature Sensor

A temperature sensor is exactly what it sounds like — a
sensor used to measure ambient temperature. This
particular sensor has three pins — a positive, a ground,
and a signal. This is a linear temperature sensor. A
change in temperature of one degree centigrade is equal
to a change of 10 millivolts at the sensor output. The
TMP36 sensor has a nominal 750 mV at 25°C (about
room temperature). In this circuit, you'll learn how to
integrate the temperature sensor with your RedBoard,
and use the Arduino IDE’s serial monitor to display the
temperature.

When you’re building the circuit be careful not
to mix up the transistor and the temperature
sensor, they’re almost identical. Look for
“TMP” on the body of the temperature sensor.

5 volt
TMP36
(Precision Temperature Sensor)
vce
vouT |2
GND
—L_ GND
= (Ground)
Temp. Sensor Wire
x1 x5

FRONT

R
SIGNAL
GND

GND
SIGNAL
+V
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Circuit 7: Temperature Sensor
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00

Before using the serial monitor, you must call Serial.begin() to

Setial.begin(9600);

=

the same speed.

initialize it. 9600 is the "baud rate", or communications speed. When
two devices are communicating with each other, both must be set to

The Serial.print() command is very smart. It can print out almost

Serial.print(degreesC);

=

anything you can throw at it, including variables of all types,
quoted text (AKA "strings"), etc.

See http://arduino.cc/en/serial/print for more info.

Serial.println(degreesF);

=

Serial.print() will print everything on the same line. Serial. printIn() will

move to the next line. By using both of these commands together, you

can create easy-to-read printouts of text and data.

What You Should See:

You should be able to read the

A O Jdev/tty.usbmodem24131
temperature your temperature

sensor is detecting on the serial a6 0.73 deq C: 23,94 deq F
L . . voltage: 0.73 deg C: 23.24 deg F:

monitor in the Arduino IDE. If it voltage: 0.73 deg C: 23.24 deg F: 73.84

isn't working, make sure you have voltage: 0.73 deg C: 23.24 deg F: 73.84

assembled the circuit correctly and VO::955 g;g geg g gg;ﬁ geg E: 72.96
. voltage: 0.73 deg C: 23.24 deg F:
verified and uploaded the code to voltage: 0.73 deg O 23.24 deg F-
your board or see the troubleshoot- | voltage: 0.73 deg C: 23.24 deg F:
ing tips below. voltage: 0.73 deg C: 22.75 deg F:
voltage: 0.73 deg C: 23.24 deg F:

voltage: 0.73 deg C: 22.75 deg F: 72.96

voltage: 0.73 deg C: 22.75 deg F: 72.96

voltage: 0.73 deg C: 23.24 deg F: 73.84

voltage: 0.73 deg C: 22.75 deg F: 72.96

voltage: 0.73 deg C: 23.24 deg F: 73.84

M Autoscroll No line ending 3]

9600 baud

Troubleshooting:

Nothing Seems to Happen

This program has no outward indication it is working. To
see the results you must open the Arduino IDE's serial
monitor (instructions on previous page).

Gibberish is Displayed

"This happens because the serial monitor is receiving data at
a different speed than expected. To fix this, click the
pull-down box that reads "*** baud" and change it to
"9600 baud".

Temperature Value is Unchanging
Try pinching the sensor with your fingers to heat it up or
pressing a bag of ice against it to cool it down.
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Real World Application:

Building climate control systems use a temperature sensor
to monitor and maintain their settings.
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CIRCUIT #8

No junction dot means no connection

5 volt
()
SIG PIN 9
C O ow . RedBoard
GND
/ GND
= (Ground)

A Single Servo

Servos are ideal for embedded electronics applications
because they do one thing very well that motors cannot —
they can move to a position accurately. By varying the
pulse width of the output voltage to a servo, you can move
a servo to a specific position. For example, a pulse of 1.5
milliseconds will move the servo 90 degrees. In this circuit,
you'll learn how to use PWM (pulse width modulation)

to control and rotate a servo.

Page 49



Circuit 8: A Single Servo
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00

#include is a special "preprocessor” command that inserts a library (or any

Hinclude <Servo.h> :> other file) into your sketch. You can type this command yourself, or
choose an installed library from the "sketch / import library" menu.

The servo library adds new commands that let you control a servo. To
Setvo servol; - . . o
prepare the Arduino to control a servo, you must first create a Servo "object
for each servo (here we've named it "servol"), and then "attach" it to a digital
servol.attach(9,900, 2100) reac ,( < ) roadig
pin (pin 9), with a minimum (900) and maximum (2100) pulse width.

The servos in this kit don't spin all the way around, but they can be commanded

Lwrite(180) to move to a specific position. We use the servo library's write() command to
servol.write H . R

move a servo to a specified number of degrees(0 to 180). Remember that the

servo requires time to move, so give it a short delay() if necessary.

What You Should See:

You should see your servo motor move to
various locations at several speeds. If the
motor doesn't move, check your

connections and make sure you have

verified and uploaded the code, or see the

troubleshooting tips below.

Troubleshooting: Real World Application:

Servo Not Twisting Robotic arms you might see in an assembly line or sci-fi
Even with colored wires it is still shockingly easy to pluga movie probably have servos in them.

servo in backward. This might be the case.

Still Not Working

A mistake we made a time or two was simply forgetting
to connect the power (red and black wires) to +5 volts
and ground.

Fits and Starts

If the servo begins moving then twitches, and there's a
flashing light on your RedBoard, the power supply you
are using is not quite up to the challenge. Using a wall
adapter instead of USB should solve this problem.
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CIRCUIT #9

5 volt

Sr=H

B4 Flex Sensor

PIN A

RedBoard

A

A
VWV

_L GND
~ (Ground)

= Resistor (10K ohm)
1 (Brown-Black-Orange)

Flex Sensor

10KQ Wire
Resistor
x1 x11

Flex Sensor

In this circuit, we will use a flex sensor to measure,
well, flex! A flex sensor uses carbon on a strip of
plastic to act like a variable resistor, but instead of
changing the resistance by turning a knob, you
change it by flexing (bending) the component. We
use a "voltage divider" again to detect this change in
resistance. The sensor bends in one direction and the
more it bends, the higher the resistance gets; it has a
range from about 10K ohm to 35K ohm. In this
circuit we will use the amount of bend of the flex
sensor to control the position of a servo.
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Circuit 9: Flex Sensor
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00

Because the flex sensor / resistor combination won't give us a
servoPosition = map(flexPosition, 600, 900, 0, 180); |:> full 0 to 5 volt range, we're using the map() function as a
map(value, fromLow, fromHigh, toLow, toHigh) handy way to reduce that range. Here we've told it to only

expect values from 600 to 900, rather than 0 to 1023.

Because map() could still return numbers outside the "to"
. . . range, we'll also use a function called constrain() that will
servoPosition = constrain(servoPosition, 0, 180); B Ag ”’ . ) 0 .
constrain(x, a, b) :> clip” numbers into a range. If the number is outside the

range, it will make it the largcsr or smallest number. If it is

within the range, it will stay the same.

What You Should See:

You should see the servo motor move in
accordance with how much you are
flexing the flex sensor. If it isn't
working, make sure you have assembled
the circuit correctly and verified and
uploaded the code to your board or see
the troubleshooting tips below.

Troubleshooting: Real World Application:

Servo Not Twisting Controller accessories for video game consoles like
Even with colored wires it is still shockingly easy to plug a Nintendo’s “Power Glove” use flex-sensing technology. It
servo in backwards. This might be the case. was the first video game controller attempting to mimic

hand movement on a screen in real time.
Servo Not Moving as Expected
The sensor is only designed to work in one direction. Try
flexing it the other way (where the striped side faces
out on a convex curve).

Servo Doesn’t Move very Far
You need to modify the range of values in the call to the
map() function.
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CIRCUIT #10

Soft Potentiometer

RedBoard T ; ;
In this circuit, we are going to use yet another kind of

variable resistor — this time, a soft potentiometer (or
soft pot). This is a thin and flexible strip that can
detect where pressure is being applied. By pressing
Resistors (330 ohm) down on various parts of the strip, you can vary the
(Orange-Orange-Brown) resistance from 100 to 10K ohms. You can use this
ability to track movement on the soft pot, or simply
as a button. In this circuit, we'll get the soft pot up
and running to control an RGB LED.

5 volt

RedBoard Soft Pot L

Resistor (10K ohm)
(Brown-Black-Orange)

@ LED
(Light-Emitting Diode)

_1 GND
= (Ground)

LED Soft Potentiometer  Wire 330Q 10KQ
E Resistor Resistor
x1 x1 x9 x3 x1
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Circuit 10: Soft Potentiometer
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1 , i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 10

Code to Note: 0 °

|:> These big, scary functions take a single

redValue = constrain(map(RGBposition, 0, 341, 255, 0), 0, 255) Value (RGBposition) and calculate the

+ constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); three RGB values necessary to create a

rainbow of color. The functions create
three "peaks" for the red, green, and

greenValue = constrain(map(RGBposition, 0, 341, 0, 255), 0, 255) blue values, which overlap to mix and

' ; colors. See the code f
- constrain(map(RGBposition, 341, 682, 0,255), 0, 255); ereate new colors. See the code for more

information! Even if you're not 100%
clear how it works, you can copy and

aste this (o any) function i
blueValue = constrain(map(RGBposition, 341, 682, 0, 255), 0, 255) paste this (or any) function into your

- constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); own code and use it yourself. If you

want to know more about creating your

own functions - take a look at circuit

#11.

What You Should See:

You should see the RGB LED change
colors in accordance with how you
interact with the soft potentiometer.
If it isn't working, make sure you
have assembled the circuit correctly
and verified and uploaded the code to
your board, or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color The knobs found on many objects, like a radio for
With the four pins of the LED so close together, it’s instance, are using similar concepts to the one you just
sometimes easy to misplace one. Try double checking each completed for this circuit.

pin is where it should be.

Bizarre Results

"The most likely cause of this is if you’re pressing the
potentiometer in more than one position. This is normal
and can actually be used to create some neat results.

// 888
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Piezo Buzzer

In this circuit, we'll again bridge the gap between the
P|ezo Buzzer digital world and the analog world. We'll be using a
buzzer that makes a small "click" when you apply
voltage to it (try it!). By itself that isn't terribly
B D F exciting, but if you turn the voltage on and off
hundreds of times a second, the buzzer will produce a
Red Board tone. And if you string a bunch of tones together,

you've got music! This circuit and sketch will play a

classic tune. We'll never let you down!

"~ (Ground)

Piezo Buzzer Wire

+ If the buzzer doesn't easily fit
into the holes on the breadboard,
try rotating it slightly.
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J ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 11

char notes[] = "cdfda ag cdfdg of "";

=

char names[] = {'c','d",'¢','f",'g",'a','b",'C'};

tone(pin, frequency, duration); :>

What You Should See:

You should see - well, nothing!
But you should be able to hear a
song. If it isn't working, make
sure you have assembled the
circuit correctly and verified and
uploaded the code to your board
or see the troubleshooting tips
below.

RNy

Troubleshooting:

No Sound

Given the size and shape of the piezo buzzer it is easy to
miss the right holes on the breadboard. Try double
checking its placement.

Can't Think While the Melody is Playing
Just pull up the piezo buzzer whilst you think, upload
your program then plug it back in.

Feeling Let Down and Deserted

"The code is written so you can easily add your own songs.
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Up until now we've been working solely with numerical data, but
the Arduino can also work with text. Characters (single, printable,
letters, numbers and other symbols) have their own type, called
"char". When you have an array of characters, it can be defined
between double-quotes (also called a "string"), OR as a list of

single-quoted characters.

One of Arduino's many useful built-in commands is the tone()
function. This function drives an output pin at a certain
frequency, making it perfect for driving buzzers and speakers. If
you give it a duration (in milliseconds), it will play the tone then

stop. If you don't give it a duration, it will keep playing the tone

forever (but you can stop it with another function, noTone() ).

Real World Application:

Many modern megaphones have settings that use a loud
amplified buzzer. They are usually very loud and quite
good at getting people’s attention.

1,'



BC337

5 volt

Diode
(1N4148) DC Motor
RedBoard
Transistor
) (BC337)
Resistor (330 ohm)
(Orange-Orange-Brown)
GND
= (Ground)

Transistor Diode
1N4148
x1 x1

EMITTER
BASE
COLLECTOR

COLLECTOR
BASE
EMITTER

Spinning a Motor

Remember before when you played around with a servo
motor? Now we are going to tackle spinning a motor.
‘This requires the use of a transistor, which can switch a
larger amount of current than the RedBoard can. When
using a transistor, you just need to make sure its
maximum specs are high enough for your use. The
transistor we are using for this circuit is rated at 50V and
800 milliamps max — perfect for our toy motor! When
the motor is spinning and suddenly turned off, the
magnetic field inside it collapses, generating a voltage
spike. This can damage the transistor. To prevent this, we
use a "flyback diode", which diverts the voltage spike
around the transistor.

When you're building the circuit be careful not
' to mix up the transistor and the temperature
- sensor, they’re almost identical. Look for

“BC337” on the body of the transistor.

Wire 330Q
Resistor
x6 x1
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Circuit 12 : Spinning a Motor
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J ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 12

00

‘The RedBoard's serial port can be used to receive as well as send data.
Because data could arrive at any time, the RedBoard stores, or
. . - "buffers” data coming into the port until you're ready to use it. Th
while (Serial.available() > 0) :> b i g Into the port you dy to s <
Serial.available() command returns the number of characters that the
port has received, but haven't been used by your sketch yet. Zero

means no data has arrived.

If the port has data waiting for you, there are a number of ways for
you to use it. Since we're typing numbers into the port, we can
speed = Serial.parselnt(); :> use the handy Serial.parseInt() command to extract, or "parse”

integer numbers from the characters it's received. If you type "1"

"0" "0" to the port, this function will return the number 100.

What You Should See:

The DC Motor should spin if you have
assembled the circuit’s components correctly,
and also verified/uploaded the correct code. If
your circuit is not working check the
troubleshooting section below.

Troubleshooting: Real World Application:

Motor Not Spinning Radio Controlled(RC) cars use Direct Current(DC)
If you sourced your own transistor, double check with motors to turn the wheels for propulsion.

the data sheet that the pinout is compatible with a
BC337 (many are reversed).

Still No Luck

If you sourced your own motor, double check that it will
work with 5 volts and that it does not draw too much
power.

Still Not Working

Sometimes the RedBoard will disconnect from the
computer. Try un-plugging and then re-plugging it into
your USB port.
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Relays

In this circuit, we are going to use some of the lessons we
5 volt learned in circuit 12 to control a relay. A relay is basically
o ey an electrically controlled mechanical switch. Inside that
harmless looking plastic box is an electromagnet that,

when it gets a jolt of energy, causes a switch to trip. In
3'&32 1 this circuit, you'll learn how to control a relay like a pro
1 — giving your RedBoard even more powerful abilities!
SPDT Relay LEDs
RedBoard Transistor ¥ fgzmgm.gmmmg Diodes)

(BC337)
Resistor (330 ohm)

0 -0 -Bi .
(Orange-Orange-Biown) i When the relay is off, the COM (common)
GND

- pin will be connected to the NC (Normally
Closed) pin. When the relay is on, the COM
] (common) pin will be connected to the NO
(Normally Open) pin.
Relay Transistor Diode 330Q LED Wire
BC337 1N4148 Resistor /
x1 x1 x2 x2 x14
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Circuit 13: Relays
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1 ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 13

=

digitalWrite(relayPin, HIGH);

digitalWrite (relayPin, LOW);

What You Should See:

You should be able to hear the
relay contacts click, and see the
two LEDs alternate illuminating
at 1-second intervals. If you
don't, double-check that you
have assembled the circuit
correctly, and uploaded the
correct sketch to the board. Also,
see the troubleshooting tips below.

Troubleshooting:

LEDs Not Lighting
Double-check that you've plugged them in correctly. The
longer lead (and non-flat edge of the plastic flange) is the

positive lead.

No Clicking Sound
"The transistor or coil portion of the circuit isn't quite
working. Check the transistor is plugged in the right way.

Not Quite Working

The included relays are designed to be soldered rather than
used in a breadboard. As such you may need to press it in
to ensure it works (and it may pop out occasionally).
When you're building the circuit be careful not to mix up
the temperature sensor and the transistor, they’re almost
identical.
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When we turn on the transistor, which in turn energizes the
relay’s coil, the relay's switch contacts are closed. This connects the
relay's COM pin to the NO (Normally Open) pin. Whatever
you've connected using these pins will turn on. (Here we're using

LEDs, but this could be almost anything,)

The relay has an additional contact called NC (Normally Closed).
The NC pin is connected to the COM pin when the relay is OFF.
You can use either pin depending on whether something should
be normally on or normally off. You can also use both pins to

alternate power to two devices, much like railroad crossing

warning lights.
oo

Real World Application:

Garage door openers use relays to operate. You might be
able to hear the clicking if you listen closely.




CIRCUIT #14

5 volt

Resistors (330 ohm)

N2 A7E o |8 (Orange-Orange-Brown)
k=] w Bt AW
E[PiN3 Y @ £t A N\
3 10 2 N AW
=1 —2Q s o ) X WW\-
& 3 [N A
PIN 4 Ak G N WW
o PSP —WW—t
8 ka8 B
Z Sl AN, N
N oH o r VWy N
——1 on o f—— A\Y
LEDs
74HC595 (Light-Emitting Diodes)

—L_GND

= (Ground) *Do not connect pin 9

LED 330Q
Resistor

x1 x8

@
-

Bend legs to 90° angle.

Wire

Shift Register

Now we are going to step into the world of ICs (integrated
circuits). In this circuit, you'll learn all about using a shift
register (also called a serial-to-parallel converter). The shift
register will give your RedBoard an additional eight outputs,
using only three pins on your board. For this circuit, you'll
practice by using the shift register to control eight LEDs.

PP PP L L

GND

Align notch on top,
inbetween “e5” and “f5” on
x19 the breadboard. The notch

indicates where pin 1 is. /
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Circuit 14: Shift Register
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1 ’ i Open Arduino IDE // File > Examples > SIK Guide > Circuit # 14

00

:> You'll communicate with the shift register (and a lot of other parts) using an
interface called SPI, or Serial Peripheral Interface. This interface uses a data
shiftOut(datapin, clockpin, MSBFIRST, data); line and a separate clock line that work together to move data in or out of
the RedBoard at high speed. The MSBFIRST parameter specifies the order
in which to send the individual bits, in this case we're sending the Most

Significant Bit first.

:> Bits are the smallest possible piece of memory in a computer; each one can
store cithera "1" ora "0". Larger numbers are stored as arrays of bits.

. . . ) . Sometimes we want to manipulate these bits directly, for example now when

bitWrite(data,desiredPin,desiredState); ’

we're sending eight bits to the shift register and we want to make them 1 or 0

to turn the LEDs on or off. The RedBoard has several commands, such as

bitWrite(), that make this easy to do.

What You Should See:

You should see the LEDs light up
similarly to circuit 4 (but this
time, you're using a shift register).
If they aren't, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board. See the
troubleshooting tips below.

Troubleshooting: Real World Application:

The RedBoard's power LED goes out Similar to circuit #4, a scrolling marquee display delivers
This happened to us a couple of times, it happens when a message with multiple LEDs. Essentially the same task
the chip is inserted backward. If you fix it quickly the shift register achieves here in Circuit #14.

nothing will break.

Not Quite Working

Sorry to sound like a broken record but it is probably
something as simple as a crossed wire.

Frustration ‘ {
Shoot us an e-mail, this circuit is both simple and

complex at the same time. We want to hear about

problems you have so we can address them in future

editions: techsupport@sparkfun.com
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LCD

In this circuit, you'll learn about how to use an LCD.

An LCD, or liquid crystal display, is a simple screen

16x2 LCD
that can display commands, bits of information, or
8o, BE882885 readings from your sensor - all depending on how you
2o22fu88888888 <«
e T program your board. In this circuit, you'll learn the
J basics of incorporating an LCD into your project.
PNz]
P3| 5
§ T
PINS| B
PN 11] O
aND PIN 12|
t(Ground)
LCD Potentiometer Wire
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{ , ‘l Open Arduino IDE // File > Examples > SIK Guide > Circuit # 15

00

This bit of code tells your Arduino IDE to include the library for a
#include <LiquidCrystal.h> :> simple LCD display. Without it, none of the commands will work,

so make sure you include it!

This is the first time you’ll fire something up on your screen. You
led.print(“hello, world!); :> may need to adjust the contrast to make it visible. Twist the
potentiometer until you can clearly see the text!

What you Should See:

Initially, you should see the
words “hello, world!” pop up
on your LCD. Remember you
can adjust the contrast using
the potentiometer if you can’t
make out the words clearly. If
you have any issues, make sure
your code is correct and
double-check your
connections.

Troubleshooting: Real World Application:

The Screen is Blank or Completely Lit? LCDs are everywhere! From advanced LCDs like your
Fiddle with the contrast by twisting the potentiometer. If television, to simple notification screens, this is a very
it’s incorrectly adjusted, you won’t be able to read the common and useful display!
text.
Not Working At All?
Double check the code, specifically that you include the o
LCD library. Cﬂ ﬂ D D
> <
Screen Is Flickering DD DQ ul DQ DD

Double check your connections to your breadboard and

Arduino. —=== O
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CIRCUIT #16

Simon Says

Piezo Buzzer
Now that we've learned all the basics behind the
components in the SIK, let's put them together and
have some fun. This circuit will show you how to

Resistors (330 oh LEDs H B

create your own Simon Says game. Using some LEDs,

some buttons, a buzzer and some resistors, you can

create this and other exciting games with your SIK.

=
=
>

Blue

(PN F——W———P+—1
Green
BN 10— W———+—
Buttons —— Red
1 PIN 6 £
——x o
Pzl (Ground)
———{omg]
GND
(Ground)

330Q LED Push Button Piezo Buzzer Wire
s I eSS, ©
x4 x4 x4 x1 x16
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Circuit 16: Simon Says
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‘ , ‘l Open Arduino IDE // File > Examples > SIK Guide > Circuit #16

00

The #define statement is used to create constants in your code. Constants are variables that
will likely only have one value during the lifespan of your code. Thus, you can assign

#define :> constants a value, and then use them throughout your code wherever you need them.
Then, if you need to change that value, you only have to change one line instead of going
through all the code to find every instance of that variable.

Bytes are another variable type. In the world of computing, a byte is a chunk of space that

byte :> contains 8 bits, and a bit is a single binary value. Binary is another way of counting and uses
only I'sand 0's. So a byte can hold all 1's: 11111111, all 0's: 00000000, or a combination of
the two: 10010110.

What You Should See:

With the circuit complete,
plug the Arduino in to a
power source. Once powered,
the buzzer will beep a few times,
and all four LEDs should begin blinking.
‘The game begins once you press any of the
four buttons. Once the game has been started, a
random LED will blink. Press the button
associated with that color LED to replicate the
pattern. With a successful guess, the pattern will
repeat, this time adding another random LED. The
player is to follow the pattern for as long as possible,
with each successful guess resulting in an additional
layer of complexity added to the original pattern.

Troubleshooting: Real World Application:

Only half the circuit works Toys and games, such as the original Simon from Milton
If only half of your circuit is working, make sure you added the Bradley, have relied on electronics to provide fun and
additional wire from one ground rail to the other. Remember that entertainment to children across the world.

breadboards have two power rails on each side and that these can
be connected, or bussed, together to provide the power to both
sides of the same circuit.

No sound

Once the buzzer is in the breadboard, it's hard to see the legs and
which row they are connected to. If you aren't hearing any sound,
make sure your wires are on the same row as the buzzer legs.

Game is not working

If everything starts up ok, but you're having trouble when it comes
time to play the game, you may have a button or two misplaced.
Pay close attention to which pin is connected to each button, as it
matters which button is pressed when a particular color lights up.
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Going Further

Visit us Online:

Tis is just the beginning of your exploration into embedded
electronics and coding. Our website has a wealth of tutorials to
whet your appetite for more knowledge. We also host a
community of hackers, engineers, DIYers, etc. in our forums.
For additional circuits, projects, and expansion packs for your
Inventor’s Kit, please visit our website!

e
¢ ) www.sparkfun.com/SIK




Begin your Joumey N The SparkFun Inventor’s Kit

teaches basic programming,

into Electronics for which you will need both

This kit will guide you through a computer and an internet connection.

experiments of varying difficulty
as you learn all about embedded

systems, physical computing, You will also learn to assemble 16
programming and more! This kit basic physical electronic circuits, but
is perfect for anyone who wants no soldering is required. No

to explore the power of the previous experience is necessary!

RedBoard platform.

4
parkfun.

SparkFun RedBoard RGB LED Photo Resistor 330 ohm resistors
Breadboard Temperature sensor Transistors Piezo buzzer
Instruction booklet DC motor Jumper wires Flex sensor
Sealed relay 8-bit shift register USB cable Soft potentiometer
Small servo Push button switches  Signal diodes Baseplate

LEDs Potentiometer 10k ohm resistors LCD
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