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1. Introduction

1.1 Overview

This document is the User Manual for the Skywire® Sensor Shield when used
with chipKIT WF32 development kit. Throughout the document Skywire Sensor
Shield will often be referred to as 'the shield', although it may be referred to by its
full name.

The NimbeLink Skywire modem is available with bundled data plans from leading
cellular carriers. The Skywire cellular modem and antennas are sold separately.

Make sure you check NimbeLink's Skywire Sensor Shield product page for the
most up to date information

1.2 Product Description

Connect the Microchip WF32 development platform to the Internet of Things
(lIoT) quickly and easily with NimbeLink's Skywire Sensor Shield. Whether you
are a hobbyist or a developer preparing a product for launch, NimbeLink's shield
and your choice of NimbeLink Skywire plug-in cellular modems will provide the
cellular connectivity you need. With Cellular connectivity, several included
sensors, and example code you can have your proof of concept up and running
in minutes with a clear path to production.

e Skywire socket that supports 2G, 3G, and 4G modems

e NimbelLink’s certified modems and bundled data plans can have you
connected to the network faster than any other cellular solution

e Four sensors to demonstrate your loT solution (Temperature,
Acceleration, Pressure, and Humidity)

e Example code to upload sensor data to Verizon Thingspace.io
dashboards
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1.3 Orderable Parts

Skywire Sensor Shield (includes

NL-AB-ST-NCL antenna and power supply) NimbeLink
Skywire 1xRTT Cellular Modem without :
NL-SW-1XRTT-V | data plan. 2G Modem. NimbelLink Verizon | 2G CDMA 1xRTT
Skywire EVDO Cellular Modem without )
NL-SW-EVDO-V | data plan. 3G Modem. NimbeLink Verizon 3G CDMA EVDO
1G.30.8113 Cellular Antenna Taoglas
TDGL021 chipKIT WF32 loT development kit Microchip

1.4 Additional Resources

NimbeLink's Skywire Sensor Shield Product Page
NimbeLink's Skywire Sensor Shield Schematic
NimbelLink's Skywire 2G 1xRTT Product Page
NimbeLink's Skywire 3G GSM/HSPA+ Product Page
NimbeLink's Skywire 3G CDMA/EVDO Product Page
Microchip chipKIT WE32 Platform Page
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http://www.digikey.com/product-detail/en/NL-AB-ST-NCL/1477-1020-ND/5235972
http://www.digikey.com/product-detail/en/NL-SW-1XRTT-V/1477-1000-ND/4494359
http://www.digikey.com/product-detail/en/NL-SW-EVDO-V/1477-1002-ND/4573469
http://www.digikey.com/product-detail/en/TG.30.8113/931-1213-ND/3724547
http://www.microchipdirect.com/ProductSearch.aspx?keywords=TDGL021
https://nimbelink.com/microchip-chipkit-wf32-cellular/
https://nimbelink.com/wp-content/uploads/2016/01/20021-RevB-Schematic.pdf
https://www.nimbelink.com/2g-cdma-1xrtt/
https://www.nimbelink.com/skywire-hspa/
https://www.nimbelink.com/skywire-evdo/
http://chipkit.net/wpcproduct/chipkit-wf32/

2. Technical Specifications

2.1 Block Diagram

IOH Header |IOL Header

SKYWIRE .

5TLMTS LPS331AP

SOCkEt Temperature Pressure

ZGJ 3G & 4G Sensor Sensor
CDMA & GSM

LIS3DH HT5221
3-Axis Humidity

Accel Sensor

Antenna

POWER Header AD Header
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2.2 Pinout

Table 2.2.1 Shield Default Pinout

100 10L Skywire DOUT
101 I0L Skywire DIN

102 10L No Connect

103 I0L Button 1

104 0L LM75 INT

105 I0L LIS3DH INT1
106 1oL HTS221 DRDY
107 I0L LPS331 INT1
108 IOH No Connect

109 IOH Skywire Reset
1010 I0H Skywire DTR
1011 IOH Skywire RTS
1012 IOH Skywire ON/OFF
1013 IOH Skywire CTS
GND IOH GND

AREF IOH No Connect
SDA IOH I12C_SDA

SCL IOH 12C_SCL

All Pins AD LEDs/Analog Sensors
VIN POWER 12 VInput

GND POWER GND

5V POWER 5V Input (unused)
3V3 POWER 3.3V Input
RESET POWER No Connect
IOREF POWER Skywire Vref
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3. Getting Started
3.1 Operating Modes

NimbeLink's Skywire Sensor Shield is designed to be compatible with the
Microchip chipKIT WF32 board. The shield also provides headers to plug in
additional shields to further the platform's functionality. The user must ensure the
pins on expansion shields do not interfere with the pins of the Skywire Sensor
Shield.

3.1.1 UART Configuration

By default the UART connection between the Skywire and the chipKIT board
connects to UART1. The default debug interface also uses UART1 so it is
important to avoid using this line for both communications. It is recommended
that UART4 (Pins 39/40 on the chipKIT WF32 Board) be used for the debug
UART in order to avoid interference. This can be done with an external Serial to
USB cable, for example.

The Skywire defaults to an 115200 BAUD rate, 8 bit data, no parity, and 1 stop
bit. The Data Terminal Ready (DTR) and Ready To Send (RTS) lines must be
driven low from the WF32 to the modem.

3.1.2 Sensor Connections

The shield has four sensors connected to Analog/IO pins that can be polled by
the chipKIT board .

The shield also has four sensors connected to the 12C interface coming from the
chipKIT board. The shield provides 4.75K pullup resistors on the 12C interface.
On the chipKIT board used in this startup guide, the 12C interface is on pins 45
(SCL) and 46 (SDA).

See the table below for details on each sensor.

Returns the amount of

PhotoTrans surrounding light, value = 0-1023 | ADO
A digital read of the pin returns a 1

Button 1 for closed, a O for open 103
A digital read of the pin returns a 1

Button 2 for closed, a O for open AD4

Adjustable voltage divider changes
Potentiometer | output by rotating, value = 0-1023 AD5

HTS221 Humidity 0-100% RH 12C
LIS3DH 3-Axis Accelerometer 2g/4g/8g/16g 12C
PN 30089 rev 2 © NimbeLink Corp. 2017. All rights reserved. 7




Pressure

LPS331 260-1260mbar 12C
Temperature

STLM75 -55Cto 125C 12C

3.2 Required Hardware
This guide assumes the user has access to the following hardware:

Skywire chipKIT Cellular Sensor Shield

chipKIT WF32 Demo Board (or equivalent)

12 V power supply

USB A to mini-B connector (for programming the chipKIT board)
Cellular antenna

Optional: USB-to-Serial cable (for debugging)

3.3 Mounting the Shield

Before mounting the shield, verify that the following jumpers in particular are in
the correct positions as shown in the figure below:

Figure 3-1: correct jumper positions for chipKIT board.

J15: jumper should be in the ‘EXT’ position. This allows the shield to be powered
off of the chipKIT board’s external 12 V supply port instead of the USB port.

JP4/JP5: jumpers should be in the ‘AN’ positions to disconnect the 12C bus from
the analog sensor ports.
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The Shield is designed to interface with the Arduino compatible headers on the
chipKIT development board. To mount the shield, orient the pins correctly over
the Arduino headers and press down on the shield until the shield is seated fully.
There should be no unconnected pins below the shield.
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Figure 3-3: Skywire Shield mounted on chipKIT board
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3.4 Skywire Placement

The Skywire Cellular modem is designed to be placed as shown below.

Figure 3-4: Skywire Sensor Shield with Skywire 3G EVDO Modem

To mount your Skywire Cellular modem follow these steps:
1. Gather the following:

a. Skywire Sensor Shield

b. Skywire Cellular Modem

c. U.FL extractor tool (Always use a U.FL extractor tool when placing or
removing U.FL cables on the Skywire modem to avoid damaging the U.FL
connectors).

2. Line up the Skywire cellular U.FL connector(s) with the circles inside the
shield’s Skywire socket footprint. Depending on the type of Skywire Modem there
may be one or two U.FL connections.

3. Carefully seat your Skywire into the shield’s Skywire socket (J6). Take care to
ensure that the pins are correctly aligned. Failure to properly align the pins may

damage your Skywire!
4. Attach the U.FL cable to the U.FL connector marked X1 on the Skywire
modem.
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3.5 Programming the chipKIT board

To program the chipKIT board while the Skywire Shield is mounted, remove the
jumpers from J3 and J4 on the shield to disconnect the Skywire modem from the
serial communication lines used for programming. Then, download the chipKIT
board software, MPIDE, from the chipKIT website:

http://chipkit.net/mpide
and follow the steps below to program the chipKIT board:

e Follow the MPIDE installation guide referenced on the MPIDE download
page (Windows, Mac, Linux)

e Download the Skywire_chipKIT_Dweet.zip file from
http://nimbelink.com/drivers/Skywire_chipKIT_Dweet.zip

e Extract the zip file to the MPIDE sketchbook folder, located by default in your
“My Documents” directory

e Within MPIDE, open the extracted pde file: ‘File -> Open ->
Skywire_chipKIT_Dweet -> Skywire_chipKIT_Dweet.pde

e Remove jumpers from J3 and J4 on the shield
e Power the chipKIT board and shield using the external 12 V power jack
e Connect the chipKIT board to your computer via USB

e Within MPIDE: Select ‘Tools -> Serial Port -> COM# (where # corresponds
with the COM port assigned to your chipKIT board)

e Select ‘Tools -> Board -> chipKIT board -> chipKIT WF32’
e Select the ‘Upload’ button

e Wait for the upload to finish. The LD1 and LD2 LEDs should be flashing
during this process

Before running:
e Disconnect USB cable from the chipKIT board
e Unplug the power cord from the chipKIT board and shield

e Reconnect jumpers on J3 and J4
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Left: programming configuration; Right: normal operation

3.6 Viewing the Device Data

Once your chipKIT board is programmed and has a mounted shield, the following
steps can be used to view the data being posted to the cloud by your device:

Make an account at https://freeboard.io/ if you do not already have one
Go to https://freeboard.io/board/6Xxpac and make a copy of the dashboard
by clicking on the "Clone" button in the lower right corner
Open the cloned dashboard and click on "skywire" under "Datasources”
Replace the "Thing Name" field with your modem's MEID or IMEI and select
"Save"

e Power on your chipKIT board and shield and wait for the green LED to start
flashing on the shield

At this point, your dashboard widgets should begin updating in real-time as your
device uploads its sensor data to dweet.io.

3.7 Troubleshooting

If you are unable to view your device's data on freeboard.io after going through
the steps in the previous sections, try the following troubleshooting options:
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e Make sure the shield has jumpers on J3 and J4 to allow the chipKIT board to
send serial commands to the modem.

e If the shield's green LED is flashing, verify that the data is being uploaded to
dweet.io by going to https://dweet.io/get/latest/dweet/for/<thingname>, where
<thingname> is replaced by the MEID or IMEI of your modem. If your
device's data is displayed there, check that the correct thing name is entered
under the "Data Sources" section of your freeboard.io dashboard.

e The following requires a USB-to-UART Serial cable: If the green LED is
not flashing, power off the chipKIT board and remove the shield. Then, place
a wire in pin 40 on the chipKIT board and re-mount the shield. Connect the
"GND" wire of the USB-to-Serial cable to J4 on the chipKIT board (ground)
and the "RX" pin to the wire in pin 40 of the chipKIT board. Power on the
chipKIT board and shield. Using a terminal program such as Tera Term or
PuTTY, open a serial connection with 115200 BAUD, 8-bit, no parity, and 1
stop bit to view the debugging trace statements from the chipKIT board.

e The following requires a Skywire Development Kit: Follow the
instructions at

http://nimbelink.com/wp-content/uploads/2014/08/User-Manual-Skywire-Dev
elopment-Kit.pdf

to verify that your modem is activated and is able to connect to the cellular
network.
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